27194: Acronis Backup & Recovery 11: Installation Fails with "Connection string for database acronis_cms is not found"

Submission of a form on this page has been disabled as you do not have JavaScript enabled in your browser. If you think this message is wrong - then just refresh the page.
Printer-friendly version

Modify a registry key to resolve the issue

This article applies to:

  • Acronis Backup & Recovery 11 Advanced Server
  • Acronis Backup & Recovery 11 Virtual Edition
  • Acronis Backup & Recovery 11 Advanced Server - Virtual Edition
  • Acronis Backup & Recovery 11 Advanced Workstation

Symptoms

  1. You attempt to install Acronis Backup & Recovery 11 Management Server on a clean machine or over Acronis Backup & Recovery 10 Management Server;
  2. Installation fails;
  3. You see the following error in the installation log:

    1: MSIGEN:CommonError: code:8356354, message:, linetag:6140929881924867570, CommonError: code:8323601, message: Connection string for database acronis_cms is not found., linetag:6140929881924867229
    1: MsiManagementServerServiceInstall: Failed to repair database connection strings: 8356354

(!) For more information on creating and analyzing installation log see Creating an MS Installer Log of Acronis Software and Analyzing Installation Logs of Acronis Products Based on MSI Technology.

Cause

A registry key that is necessary for installation is missing.

Solution

  1. Open Windows registry: go to Start -> Run -> regedit;
  2. Locate the following registry key: HKLM\SOFTWARE\Acronis\AMS\ConnectionStrings\acronis_cms
  3. Right-click on this key, select Export and save the key as .reg file:

  4. Right-click on the saved registry key and select Open with -> Notepad;
  5. The file in Notepad will look similar to this:

  6. In the line [HKEY_LOCAL_MACHINE\SOFTWARE\Acronis\AMS\ConnectionStrings], add "Wow6432Node": [HKEY_LOCAL_MACHINE\SOFTWARE\Acronis\Wow6432Node\AMS\ConnectionStrings]

  7. Save the changes to the .reg file;
  8. Double-click on the .reg file to reimport the key and add changes to the registry:

  9. Reattempt the installation.

More information

Contact Acronis Customer Central if you have any questions or need assistance.

Provide feedback on this information

Please use the form below to send us your comments. We read all feedback carefully.

Please note that we cannot individually respond to all comments. We do read, analyze and work to improve our content, products and services based off the feedback we receive. Should you need technical or customer service assistance please use our Contact Support Wizard.

Thank you for taking the time to send us your thoughts, we truly value your input.

To protect your privacy, do not include contact information in your feedback.