
Modify a registry key to resolve the issue
This article applies to:
- Acronis Backup & Recovery 11 Advanced Server
- Acronis Backup & Recovery 11 Virtual Edition
- Acronis Backup & Recovery 11 Advanced Server - Virtual Edition
- Acronis Backup & Recovery 11 Advanced Workstation
Symptoms
- You attempt to install Acronis Backup & Recovery 11 Management Server on a clean machine or over Acronis Backup & Recovery 10 Management Server;
- Installation fails;
- You see the following error in the installation log:
1: MSIGEN:CommonError: code:8356354, message:, linetag:6140929881924867570, CommonError: code:8323601, message: Connection string for database acronis_cms is not found., linetag:6140929881924867229
1: MsiManagementServerServiceInstall: Failed to repair database connection strings: 8356354
(!) For more information on creating and analyzing installation log see Creating an MS Installer Log of Acronis Software and Analyzing Installation Logs of Acronis Products Based on MSI Technology.
Cause
A registry key that is necessary for installation is missing.
Solution
- Open Windows registry: go to Start -> Run -> regedit;
- Locate the following registry key: HKLM\SOFTWARE\Acronis\AMS\ConnectionStrings\acronis_cms
- Right-click on this key, select Export and save the key as .reg file:

- Right-click on the saved registry key and select Open with -> Notepad;
- The file in Notepad will look similar to this:

- In the line [HKEY_LOCAL_MACHINE\SOFTWARE\Acronis\AMS\ConnectionStrings], add "Wow6432Node": [HKEY_LOCAL_MACHINE\SOFTWARE\Acronis\Wow6432Node\AMS\ConnectionStrings]

- Save the changes to the .reg file;
- Double-click on the .reg file to reimport the key and add changes to the registry:

- Reattempt the installation.
More information
Contact Acronis Customer Central if you have any questions or need assistance.