2714: MS Virtual PC Does Not Boot from Converted VHD Disk

Submission of a form on this page has been disabled as you do not have JavaScript enabled in your browser. If you think this message is wrong - then just refresh the page.
Printer-friendly version

MS Virtual PC cannot boot from a .vhd disk larger than 127 GB

This article applies to:

  • Acronis True Image Echo
  • Acronis Backup & Recovery 10

(!) This article does not apply to Acronis True Image Home. Acronis True Image Home supports only Windows native backup (VHD) that cannot be run as a virtual machine.

Symptoms

  1. Using Acronis True Image Echo or Acronis Backup & Recovery 10 you convert a backup archive to a virtual disk in .vhd format. See also Acronis True Image Echo: V2P and P2V Migration and Acronis Backup & Recovery 10: Converting Backup Archive of a Windows System to a Virtual Machine;
  2. You add the converted .vhd disk as an IDE disk to a MS Virtual PC machine;
  3. The MS Virtual PC machine does not boot.

Cause

MS Virtual PC cannot boot from .vhd disk larger than 127 GB.

This is a limitation of IDE interface, which is the only option to connect a drive in MS Virtual PC.

Solution

Instead of converting the backup archive to a .vhd disk, restore it using Acronis Universal Restore:

  1. Create a blank virtual disk on the MS Virtual PC machine;
  2. Restore the .tib backup to the created blank virtual disk using Acronis Universal Restore. This will allow resizing the disk to a size smaller than 127 GB (provided that the hard disk from which backup is created has enough free space to allow downsizing).

More information

In MS Virtual Server there are both IDE and SCSI available. The limitation of SCSI is 2040 GB.

See also:

Provide feedback on this information

Please use the form below to send us your comments. We read all feedback carefully.

Please note that we cannot individually respond to all comments. We do read, analyze and work to improve our content, products and services based off the feedback we receive. Should you need technical or customer service assistance please use our Contact Support Wizard.

Thank you for taking the time to send us your thoughts, we truly value your input.

To protect your privacy, do not include contact information in your feedback.