2697: VSS Locks Partition after Running a Backup

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Unlock the partition using diskpart

This article applies to:

Symptoms

  1. Using Acronis True Image with Enabled Microsoft VSS support you back up your system;
  2. After the backup, the partition is locked. As a result, Database stops working, because it cannot write data to the locked partition.

Cause

VSS may lock the partition after a backup by changing the partition's attribute  to read-only.

Solution 

See Microsoft Knowledge Base Article 840781.

Unlock the partition using diskpart:

  • Click Start -> Run;
  • Issue diskpart;
  • In the command-line issue list disk;
  • select disk [number of the disk that has the locked partition];
  • list partition
  • select partition [number of the locked partition]
  • att vol clear readonly
  • att vol clear nodefaultdriveletter
  • att vol clear hidden
  • att vol clear shadowcopy

Check the partition attributes:

  • detail volume

It should display the following attributes:

  • Readonly: No 
  • Hidden: No

More information

See also Using Acronis True Image to Back Up a System with VSS.

You can also use batch files to stop the database for a second before the snapshot is taken and then immediately start it, while Acronis True Image proceeds with creating the backup. See Using Batch Files in Acronis True Image.

To investigate why exactly the partition was locked up, please do the following:

  1. Use AcronisInfo Utility to collect the necessary information;

  2. Get the VssShadowStorageReport.txt file by issuing the following command:

    vssadmin list shadowstorage > c:\VssShadowStorageReport.txt

  3. Contact Acronis Customer Central with the collected information and a reference to this article.

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