25350: Acronis Backup & Recovery 11: Installation over Acronis True Image Echo on Linux Removes /etc/init.d

Submission of a form on this page has been disabled as you do not have JavaScript enabled in your browser. If you think this message is wrong - then just refresh the page.
Printer-friendly version

Recreate /etc/init.d after uninstalling the old product

This article applies to:

  • Acronis Backup & Recovery 11 Server for Linux
  • Acronis Backup & Recovery 11 Advanced Server - Agent for Linux
  • Acronis Backup & Recovery 11 Virtual Edition - Agent for Linux

Symptoms

  1. You install Acronis Backup & Recovery 11 Agent for Linux on a machine where Acronis True Image Echo Server for Linux is installed. 
  2. After a reboot, the system does not start.

Cause

Issue in the product.

When installation starts, Acronis Backup & Recovery 11 Agent for Linux initiates uninstall of Acronis True Image Echo Agent for Linux. During uninstall, Acronis True Image Echo Agent for Linux removes the link /etc/init.d. This makes the system unbootable. 

Solution

The are two solutions for the described issue:

  1. Preventive This solution allows you to avoid such an issue problem before it happens.
  2. Resultive This solution allows you to solve such an issue after it happened.

Preventive solution:

  1. Uninstall Acronis True Image Echo Agent for Linux / Acronis True Image Echo Server for Linux: 
    • # cd /usr/lib/Acronis/TrueImageServer/uninstall/
    • # ./uninstall
    • # rm -rf /usr/src/snapapi*
  2. If symlink /etc/init.d is absent, create it again:
    • # cd /etc/
    • # ln -s rc.d/init.d init.d
  3. Install Acronis Backup & Recovery 11

Resultive solution:

If you did not use the preventive solution, you need to recreate the missing symlink using a Linux Live CD. If the system does not boot, boot from a Linux CD, mount the root partition and recreate the symlink:

  • # cd /etc/
  • # ln -s rc.d/init.d init.d

More information

See also Acronis Backup & Recovery 11.

Provide feedback on this information

Please use the form below to send us your comments. We read all feedback carefully.

Please note that we cannot individually respond to all comments. We do read, analyze and work to improve our content, products and services based off the feedback we receive. Should you need technical or customer service assistance please use our Contact Support Wizard.

Thank you for taking the time to send us your thoughts, we truly value your input.

To protect your privacy, do not include contact information in your feedback.