23359: Acronis Backup & Recovery: Disk Backup with Acronis VSS Provider Fails on Windows SBS and domain controllers

Event Codes: 
0x000101F6+0x00070021+0x0010C442+0x0010C469+0x0000FFF0+0x800423F0
0x0135003D+0x01490003+0x00010424+0x00070021+0x0010C442+0x0010C469+0x0000FFF0+0x800423F0

As a workaround, use Microsoft VSS instead of Acronis VSS

This article applies to:

  • Acronis Backup & Recovery 10
  • Acronis Backup & Recovery 11
  • Acronis Backup & Recovery 11.5

Symptoms

  1. You have a Windows server with Active Directory Domain Services role (an SBS system or a domain controller) and NTDS VSS writer present in the system.

(!) You can check the list of writers in the system by running "vssadmin list writers" command via Start -> Run -> cmd.

 2. You create a disk backup of this server. Option Use Volume Shadow Copy service (VSS) is selected and the snapshot provider is Software - Acronis VSS Provider.

 3. Backup operation fails with the a snapshot error similar to:

Failed to create volume snapshot

 4. Windows Application event logs contain errors similar to:

Log Name: Application
Source: ESENT
Event ID: 455
Task Category: Logging/Recovery
Level: Error
Description:
lsass (616) Error -1023 (0xfffffc01) occurred while opening logfile C:\Device\snapman\Windows\ntds\edb.log.

5. Error log shows an error similar to this:

Unknown Win32 error

Event code: 0x000101F6+0x00070021+0x0010C442+0x0010C469+0x0000FFF0+0x800423F0

or:

Event code: 0x0135003D+0x01490003+0x00010424+0x00070021+0x0010C442+0x0010C469+0x0000FFF0+0x800423F0

Cause

Problems in communication between Acronis VSS Provider and NTDS writer due to Acronis VSS Provider limitations. When Acronis VSS Provider is used for VSS support, the final snapshot is created by means of Acronis SnapAPI drivers technology. NTDS writer requires to get the snapshot path which is not possible to be done correctly with SnapAPI snapshot specifics and Acronis VSS Provider capabilities.

Solution

As a workaround, use Microsoft VSS provider instead of Acronis VSS. You will need to go the backup options into Volume Shadow Copy Service section. Make sure that the option Use Volume Shadow Copy Service (VSS) is selected. In Snapshot provider menu select the option Software - System provider.

See Acronis Backup & Recovery 11: Using Microsoft VSS instead of Acronis VSS.

(!) There may be a separate issue where backups with Microsoft VSS provider on Windows Small Business Server 2011 may not work correctly after Microsoft SharePoint Foundation 2010 Service Pack 1 (SP1) installation. 


More information

(!) This issue applies only to systems with Active Directory Domain Services and NTDS VSS writer. If you face this error on a different operating system, the issue is not covered in this article and needs investigation. Please contact Acronis Customer Central with a reference to this article.  

Segments:

Provide feedback on this information

Please use the form below to send us your comments. We read all feedback carefully.

Please note that we cannot individually respond to all comments. We do read, analyze and work to improve our content, products and services based off the feedback we receive. Should you need technical or customer service assistance please use our Contact Support Wizard.

Thank you for taking the time to send us your thoughts, we truly value your input.

To protect your privacy, do not include contact information in your feedback.