19020: Acronis Backup Software: Recovery of Large Amount of Files from a File Backup Fails

Submission of a form on this page has been disabled as you do not have JavaScript enabled in your browser. If you think this message is wrong - then just refresh the page.
Printer-friendly version

Edit the Windows registry to allocate more memory to the recovery process

This article applies to:

  • All Acronis backup software

Symptoms

An attempt to restore a large amount of files (e.g. hundreds of thousands or millions) from a file backup in Windows fails or not all of the files are recovered.

Cause

The most likely cause is an insufficient amount of memory allocated to the recovery process by the operating system's cache manager.

Solution

There are two possible workarounds:

  • Recover the files as two or more groups. For example, if the issue is with recovering 1 million files, try recovering the first 500,000 of them and then the remaining 500,000;
  • Or allocate more memory to the recovery process:

    (!) This procedure requires restarting the machine. Use standard precautions when modifying the registry.

    1. Hit Start-Run and type in regedit to invoke Windows Registry Editor;
    2. In Registry Editor, open the following registry subkey:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    3. Add the PoolUsageMaximum entry to the subkey:
      • Entry type: DWORD Value
      • Base: Decimal
      • Value: 40
    4. Add the PagedPoolSize entry to the subkey:
      • Entry type: DWORD Value
      • Base: Hexadecimal
      • Value: FFFFFFFF
    5. Quit Registry Editor, and then restart the machine.

More information

In general, if a volume contains many files, consider using a disk-level backup instead of a file-level one. In this case, you will be able to recover the entire volume as well as particular files stored on it.

Provide feedback on this information

Please use the form below to send us your comments. We read all feedback carefully.

Please note that we cannot individually respond to all comments. We do read, analyze and work to improve our content, products and services based off the feedback we receive. Should you need technical or customer service assistance please use our Contact Support Wizard.

Thank you for taking the time to send us your thoughts, we truly value your input.

To protect your privacy, do not include contact information in your feedback.