18363: Acronis Backup & Recovery Displays "This program might not have installed correctly" during Installation on Windows 7 x64 or Windows Server 2008 R2 x64

Submission of a form on this page has been disabled as you do not have JavaScript enabled in your browser. If you think this message is wrong - then just refresh the page.
Printer-friendly version

Windows Program Compatibility Assistant displays "This program might not have installed correctly". However, installation finishes successfully

This article applies to:

  • Acronis Backup & Recovery 10
  • Acronis Backup & Recovery 11

Symptoms

  1. You install Acronis Backup & Recovery on Windows 7 x64 or Windows Server 2008 R2 x64;
  2. During the installation, Windows displays the following message:

    This program might not have installed correctly

  3. The installation finishes successfully.

Cause

This is a known Microsoft issue with Windows 7 x64 and Windows Server 2008 R2.

Solution

Download and install a patch from Microsoft Knowledge Base Article 978637.

More information

Feel free to contact Acronis Customer Central if you have further questions or need assistance.

Provide feedback on this information

Please use the form below to send us your comments. We read all feedback carefully.

Please note that we cannot individually respond to all comments. We do read, analyze and work to improve our content, products and services based off the feedback we receive. Should you need technical or customer service assistance please use our Contact Support Wizard.

Thank you for taking the time to send us your thoughts, we truly value your input.

To protect your privacy, do not include contact information in your feedback.