The task script is missing
This article applies to:
Acronis True Image Echo
Acronis True Image 11 Home
Acronis True Image Home 2009
Acronis True Image Home 2010
Acronis True Image Home 2011
Acronis True Image Home 2012
Symptoms
Acronis True Image shows the No such script [Script Name] error entry the operation log. View Sample .
Windows Event Viewer shows the same error entry. View Sample .
Cause
The most possible cause is that the original task script (*.tis) was removed from the Scripts folder:
Acronis True Image Home
Windows XP : Documents and Settings\All Users\Application Data\Acronis\TrueImageHome\Scripts
Windows Vista, Windows 7 : ProgramData\Acronis\TrueImageHome\Scripts
Acronis True Image Server for Windows, Acronis True Image Workstation, Acronis True Image Enterprise Server
Windows XP, Windows 2000, Windows 2003 : Documents and Settings\All Users\Application Data\Acronis\TrueImage\Scripts
Windows Vista, Windows 7, Windows Server 2008 : ProgramData\Acronis\TrueImage\Scripts
As a result, Acronis True Image fails to run the missing task.
Solution
Since the task script is removed, unregister the task from Acronis Scheduler to get rid of the error entries.
Download Acronis Scheduler 461 and run it. This will update your Acronis Scheduler to the latest build;
Unregister the task that gives the error or unregister all tasks: Unregistering all tasks (easier option):
Download schedmgr.exe and run it:
In the command line type in task zap and hit Enter :
Unregistering a separate missing task:
Open the operation log of Acronis True Image;
(!) To view the operation log, in the main window of the program select:
Acronis True Image Home 2011: Help -> View log
Acronis True Image Home 2010: Tasks and Log -> Log
Acronis True Image Home 2009: Tasks and Log
Find the respective error entry and note the name of the mentioned script. For example:
Error 1 108 (0X1006C) 10/29/2008 12:09:02 No such script "90F1BFEE-7B23-4E67-96EE-173F00AE9AB4"
Download schedmgr.exe , which is Acronis Scheduler Manager;
Run the schedmgr.exe file and issue the following command:
get list
In the list of displayed tasks, note the number of the script that has the same name as the one that produces error entries in the log. For example:
1-3 ~*TrueImageNotify* /dummy / script: "90F1BFEE-7B23-4E67-96EE-173F00AE9AB4" /uuid: "90F1BFEE-7B23-4E67-96EE-173F00AE9AB4"
Issue the following commands (type in command line the first command and hit Enter , then type in the second command and hit Enter ):
task [Script Number]
task delete
For example:
task 1-3
task delete
If there is more than one task that produce error entries, repeat the procedure for each of them separately.
Reregister the task(s): Reregistering in Acronis True Image Home 2011:
Start the product and next to the backup task click Operations -> Edit backup settings :
Click Save :
Reregistering in Acronis True Image Home 2010:
Start the product and click Tasks & Log :
Right-click on the backup task and click Edit :
Select Finish -> Proceed :
More information
After applying the solution, the No such script should entries should stop appearing in the log.
Contact Acronis Customer Central if you have any questions or need assistance.