
You can manually update your support program information by clicking Register Renewal near the outdated support program information and submitting your Order/Invoice/License certificate number and billing e-mail.
Symptoms
You purchased or renewed Acronis Advantage support program. You log into your account and you see that the information about your support program and/or expiration date is outdated.
Cause
Sometimes support program information is not updated because of technical issues in order processing systems.
Solution
Please do the following to manually update your support program information:
- Log in to your account;
- Make sure all your Product Serial Numbers are registered under your account;
- Switch to My Products & Downloads in the upper left-hand corner of the page:

- Click Support Tab:

- Click Register Renewal link:

A pop-up window will appear:

- Type in your the requested details as prompted:
- Billing Email - E-mail Address you used to place the purchase order
- Order/Invoice No - depending on the way you purchased your product you should enter either Order ID or Invoice ID or License Certificate Number or Reference Number
- Click Submit Button. The system will verify your order information and update your Support Program and/or Expiration date according to the order details.
More information
- With valid Acronis Advantage Standard/Premier support program registered, you can receive free upgrades to the latest product versions by clicking Upgrade tab. See Receiving Upgrade Licenses for Acronis Enterprise Products for additional information.
- (!) If any issues with the submitted order information are experienced by the system, you will see the error message with the reason of failure and the prompt to click the link for getting further assistance. If you need further help, please click the link and you will be automatically forwarded to Live Chat with Acronis Representative.